Embedder Support Forum

92 Comments in 29 Topics
Embedder Plugin Support Forum » Fatal error when trying to create a global embed
Author Topic: Fatal error when trying to create a global embed 11 comments / 14273 views
stephane

I just installed this plugin (v 1.31) for the first time today. No matter what I add in the fields, I get the following error when I click on the “Add Embed” button:

Fatal error: Cannot pass parameter 1 by reference in /wordpress/wp-content/plugins/embedder/emb-admin.php on line 214

WordPress version : 3.02
Linux ISP
Apache 1.3.41
PHP 5.2.5
MySQL 5.0.81

stephane

I get the same error whether I use New Embedder Parser or not.

Martin

same here … i just tried to add an embed with a new install of wp and it only returns a blank page. and it’s not related to wordpress 3.0.3 …

stephane

I also tried to disable ALL the plugins except Embedder. No luck. Same symptoms.

moztools

Okay — sorry to hear that you are having problems. I’ll look into it.

moztools

Well, I’m not entirely sure why the line 214 was causing a problem for some people—I’m pretty sure I tested it with PHP4 and PHP5—ah well, it happens, I guess.

I removed the issue altogether by removing what was a little bit of a lazy hack in the first place, with an even lazier (but much safer) hack :).

So if you happen to read this note, stephane and Martin, if you could try version 1.3.2 and let me know if it solves your problems, I would be very grateful!

Thanks,

Mike

stephane

That did it. Thanks Mike. I haven’t tried anything else yet but with 1.3.2 I can now add a new embed without getting an error. Thanks again!

moztools

Thanks for letting me know, staphane. 🙂

stephane

Hey Mike,
Just wanted to let you know I put the new 1.3.2. plugin to use this morning and it works flawlessly. I used the new parser mode, and 5 attributes to embed Scribd docs in Flash. Your plugin is a life saver!

One quick minor note: on your website it says that “When you use attributes with global embeds, the plugin identifies the attributes you have used in an embeds and displays them in attributes column in the table.” It seems only the first attribute is shown, which is fine, but it would be nice to see them all. If not in the table, maybe in the “Edit Embed” page?

Thanks.

moztools

Hi Stephane, glad you’re enjoying the plugin, and thanks for the feedback. It’s nice to know things are working well.

Yeah, I know about the attributes in the table — I actually print them all out, but because I don’t allow enough space in the column in the table, if there’s more than one or two, the rest overflow the column and are not displayed. I’ve been meaning to tweak the column widths to fix it, so I’ll probably do it in the next version. (I probably shouldn’t put out any more updates for a few days, though, having had three in three days 🙂 )

Powered by moztools Instant Forums

Leave a Reply

Your email address will not be published. Required fields are marked *